PLUUT

PHP 5.6 End Of Life

PHP 5.6 End Of Life

PHP 5.6 komt ten einde. Deze versie van PHP is langer dan gewoonlijk in productie geweest. Welke veranderingen brengt de nieuwe versie van PHP met zich mee en hoe groot is de impact?

Een grote sprong

Aan het eind van het jaar 2018 zal PHP versie 5.6 officieel "End Of Life (EOL)" verklaard zijn. Dit betekent dat deze versie vanaf dat moment geen (security) updates meer zal krijgen.

PHP 5.6 is de allerlaatste versie in de PHP 5 reeks. Dit hebben ze bij PHP zelf bekend gemaakt.

PHP 7 is twee keer zo snel. Het is dus zeer waarschijnlijk dat je een boost in je applicatie snelheid zult zien.

Waarom zou je moeten upgraden?

De grootste veranderingen vergeleken met PHP 5 is dat PHP 7 twee keer zo snel is. Het is dus zeer waarschijnlijk dat je een boost in je applicatie snelheid zult zien. Maar ook qua resources is PHP 7 zuiniger. Voor cloud gebruikers is dit een hele grote verbetering omdat elke CPU-cycle telt! 

Het belangrijkste argument om naar PHP 7 te updaten is toch wel dat je nieuwe beveiliging updates krijgt.

Als je benieuwd bent naar wat PHP 7 biedt over PHP 5 kun je het nieuwsbericht van PHP zelf hier lezen.

Migreren van oud naar nieuw

Veel websites zijn al geüpgraded naar versie 7.1 of hoger. Voor systemen die nog PHP 5.6 gebruiken, kan het voorkomen dat het niet mogelijk is om op een eenvoudige wijze te updaten. Dit heeft vooral te maken met oude functionaliteit die wordt uitgefaseerd en functionaliteit van bestaande methodes die zullen wijzigen.

Het is daarom erg belangrijk om jouw gehele website te testen in een testomgeving voordat je de productieomgeving update naar PHP 7.1 of hoger.

De tijd dringt

PHP 5.6 zal eind 2018 geen updates meer krijgen. Dus het liefst wil je jouw website in PHP 7 al ruim door het eind van het jaar draaiende hebben in de nieuwe versie. Maar zo'n upgrade heeft nogal wat impact. Neem dus de tijd om een goed migratietraject op te zetten alvorens je aan de slag gaat!

Weet je niet of jouw website ge-update moet worden naar PHP 7.1 of hoger? Neem gerust contact met ons op. Wij kunnen dit voor jou achterhalen.